Please request registration email again and then check your "Spam" folder


[HHS+ 1.10.6] Official Bug Report Thread (Check OP)

Started by barteke22, May 27, 2022, 11:39 PM

Previous topic - Next topic

barteke22Topic starter

For bug reports for the full 1.10.6 release.  This is for actual bugs only (broken logic)!  Please don't report the same issue both here and on discord.
For typos see the Official Typo Thread.
For balance issues (numbers or inconsistencies) see the Game balance discussion thread.
For hopes and dreams (changes/suggestions) that may never be, see the Feature requests and wishlists thread.

If a report has been 'liked' by an admin, then it's confirmed and fixed internally. Issues assumed solved will be purged when the relevant patch comes out.

Issues tracked currently:
- Should be fixed, but if you run into 'Insufficient memory' issues, report & switch Settings > Gfx > High GPU.
-- We do want people testing High RAM / Balanced if possible, as those will be the main modes in the future.
- Detention: Got a bandaid fix while it waits for scheduling overhaul.

Low priority as it could take a while:

In next fixes:

Self help
Will list some bugfixes if you're impatient. In all cases Debug > Debug Events the file, top right filter jumps to IDs.

- PersonAttachedEvents\RaymundChain\Sherilyn_Encounters: Connect ID 628's 0 to ID 596's In instead.
- FunctionLibrary\GenSexHandling\Misc\RulePenalty: Connect ID 59's Some to ID 67's 0.7.
- Visit button in Apartments: Copy Btn_GotoGenNPCHomeLocal from Events\Location\City Streets Shared to ...\Apartment Building (reload events on existing saves).

- BeachGirlsMix: Connect the nearby girl Object to ID 475.
- Carl: If you want the fem/futa route, use fake drugs (available at low chem), or Debug > Person his gender before first event.
- LoveAsk: Connect missing link from ID 172 to False.

Update to 1.10.5, old:

Will list some bugfixes if you're impatient. In all cases Debug > Debug Events the file.

PersonAttachedEvents\RaymundChain\AprilClass {P2_Name} Exception:
1. Debug > Debug Events the file.
2. Change ID 131 from 1 to 2 (can filter by ID in top right).
3. Disable Single Line Mode in ID 130 + click 'Delete'.

Location\School\Principal Office\AprilOffice not getting scheduled after AprilClass (after missing student):
1. Edit > Event Properties.
2. Temporarily disable its scheduling by unticking 'Fast Schedule Check'.
3. Undo that after the event (important).

Knock/Intercom being broken (FunctionLibrary\Location\BreakInMain).
- Change the outputs of ID 305 so 1 connects to 0 and 2 to -1. Hover over Out and press Delete, then drag it.

MadScience (Location\School\Chem Lab\MadScience) instantly re-scheduling due to a missing link.
- Connect the output from ID 1549 (Out to In on its right).

Any errors saying: Unexpected end of file has occurred. The following elements are not closed: ImageMetadata.
- Open file and open relevant image (first exception ID), then close it.


Willpower -20
Some sex operations appear to be giving -20 willpower to participants, which does not seem intentional. The willpower for the PC resets back to 50 after some time, however will drop down temporarily to 32 by the change (even if starting at 50 and the notification stating -20 change).

Triggering activities (at least):
Fucking Hooter in the "dating" phase after corruption
Masturbating in the school office

Edit: Not a bug, it's just a temporary effect caused by sex, like the happiness one.  The UI notifications for them should be hidden/improved, but effect itself is as intended.


-0.01 Happiness
I'm losing 0.01 happiness every time I move after meeting Sierra Hardman in my office for the first time. This is a new game and I have yet to save. Someone on F95zone mentioned that it only happens to them when they save or load before meeting Sierra in the office for the first time, but this is not my experience. I'm also getting lag when moving to a new place.

Edit: Same as above.


On that note, I was amused that the HasQuest prostitutes will, when asked (before the quest has even started) tell you they're a prostitute. But you don't recognise them when you call them until you reach that point in the quest.

So having someone's "My job is" answer evolve based on flags makes sense, but probably isn't currently supported in the code (even though the "You already knew that" part does).

barteke22Topic starter

Modding the game to have 0 males (or females) is not supported by scenario design, therefore not really a bug.  It might be in the future, but for now it isn't.


I've hit a couple of times now where the suggestion code saw secondaries that weren't present. Once was in the home bathroom, just me and the target, and I got a "failed to hypnotise a secondary" failure. I had just saved, and reloading and trying again didn't trigger a secondary success or failure. I don't have more details of this one, as I assumed that somehow Annette had wandered into the room long enough to be counted or something. From memory this was a Have Sex action.

The second time was in the home bedroom, and actually hit a divide-by-zero which I thought warranted a closer look:
ExtensionLibrary\Suggestion\Options\ChangeBehavior\10_ChangeBehaviorMain [EXEC] caused an exception at operation SeqAct_DoubleMath (ID: 435).
    called by FunctionLibrary\Suggestion\ProcessSuggestionOptionsFromFolder at SeqActLat_RemoteEventDynamic (ID: 111)
    called by ExtensionLibrary\Suggestion\Options\10_ChangeBehavior_Category at SeqActLat_RemoteEvent (ID: 3)
    called by FunctionLibrary\Suggestion\ProcessSuggestionOptionsFromFolder at SeqActLat_RemoteEventDynamic (ID: 111)
    called by FunctionLibrary\Suggestion\Main at SeqActLat_RemoteEvent (ID: 362)
    called by Interactions\MindControl\HypnosisStandard at SeqActLat_RemoteEvent (ID: 57)
Attempted to divide by zero.

Node 435 is down in the bottom left, marked <60:  Max Total = 150 / Min Total = 75.

I'm not sure what's going on here, since looking at HypnosisStandard, there must have been an entry in the secondary targets list to even hit this point.

I'll try and catch it happening again, and see if anything else useful shows up. It's a shame that when there's an exception, I can't bring up the debugger to look at the event state.


I just had it happen again, and the secondary target text (i.e. "You also told X that anything they see was just their imagination") named the primary target. Reloading a save immediately before the action and trying again didn't reproduce the issue, annoyingly.

Anyway, this suggests that something is failing in the very first step of HypnosisStandard, since that is supposed to remove the target from the secondaries list; I don't understand how I then see in 10_ChangeBehaviorMain the Secondaries count being 0, so perhaps something else is going wrong and confounding this check.


I (unthinkingly) didn't keep the save, since it didn't reoccur when I loaded the save and tried again. It was a different NPC each time, at least one was a special, it's possible all three were.

I'll grab the save next time, and also have the debugger open when I'm running Hypno in my home to see if I can catch and inspect the state.

Late edit: I think the circumstance happened again, but didn't trigger an error (I saw the secondary text for a single-occupant hypno call), and it happened after a load this time, as I was save-scumming the hypno attempt and the first attempt was resisted; however I forgot to grab the save again, and it didn't hit the exception this time. So next time it happens, I'll make sure I hit the path that has the exception (I think it's only the Have Sex side that will hit an exception here), and keep the save game aside.


Quote from: kronosblaster on Oct 16, 2022, 08:11 AMThe image data generated an overflow during processing

You might be hitting, which has a local workaround, but can and probably should be fixed in the HHS+ codebase (see the first comment) although since I can't see the HHS+ C# code, it's possible that specific comment is inapplicable.

I'm not sure the fix in that comment is right (it depends on the context, but ignoring the colour profile smells fishy to me). The problem might well be the image data (if it has a bad colour profile embedded, but that'd be weird for every image in the game to have that issue unless someone once processed all the images using a faulty tool), or a bug in WPF itself where it mishandles certain otherwise-valid colour profile conversions.

It's also possible that the code as-is is correct, and you have a faulty colour device profile loaded on your computer somehow, and that is why the conversion fails. If that is the case, then the configuration change in that link would be the right fix after all.


Hopefully fixed most
Possible bug in FunctionLibrary\Time\ReplaceString24hTimeWithCultured.

During the long-form intro, when Lydia is explaining your office (third choice on the school tour), she said "Oh... That reminds me, your first PTA meeting is tomorrow at sixteen.", and that doesn't actually make sense: you'd say "sixteen hundred", "sixteen hundred hours" or simply "four pm" for "16:00", not just "sixteen".

The text passed in was "Oh...  That reminds me, your first PTA meeting is tomorrow at 16:00." with mode 1 (formal word), so the conversion has the right data.

Looking at the low-level event FunctionLibrary\Time\ConvertTimeToCultured, perhaps that's behaving as-intended: that VEE's comment gives "half past thirteen" as a valid output. This that also reads weirdly in English to me, 13:30 would be "thirteen-thirty".

I wonder if "words" modes (1 and 7) should always work in 12-hour time? Saying "sixteen hundred" out loud sounds very movie-military to me, not a daily-use term, and I think it's weird to hear it from a school admin, even if using a 24-hour watch display.

Is the "Futa Slavery" society goal supposed to be available to futanari principals? I'd assume that'd be blocked off, similar to how things work in the Sierra Hardman quest line. (I didn't check, but vice-versa, non-futa principals choosing "Futa (R)Evolution" society goal is a bit odd, although since there's Futa Maker down the track, that may be somewhat justifiable." Edit: I had the wrong principal loaded. Futa principal correctly doesn't offer "Futa Slavery".

Had a weird one where I opened the school Fundraiser event in the debugger before clicking the button, and it didn't offer to let me pay. On inspection in the debugger, there was a 'False' attached to the first decision (pay or not). It's not there in the on-disk version, and a reload of the event didn't show it, so I wonder if something in the debugger added the node on loading. (I can check an old save game to see if it's there then, I'll try and remember to do that later). I have some mods, but none appear to interact with this event.

Edit: I checked an older save-game from this run, and the "False" wasn't there. So I have no idea what happened here. Maybe I found a secret "Add node" hotkey or modifier-drag and accidentally hit it in the debugger? The node was new (it's ID was higher than the highest existing node) so that would make sense.

Edit: Another Debugger oddity. I just had the "Set up a meeting" scene (Carmen/Oliver line) repeat, and on examining the event in the debugger, the "set bit 4" node (ID 104 in YoungLoverPA) was not connected to the reference var above (ID 144 -> 60) as expected, but to a separate integer var. So I had the weird effect where bit 9 has been set (i.e. I heard the rumours) but not bit 4, so it played that scene again. Again, reloading the event fixed the link (and with a little bit of temporary hacking I can avoid a month of extra delay)

Like the other one, this is an event I'd opened before it ran or during an earlier run, so I suspect something is incorrectly loading events in the debugger, and changing them, i.e. if I had not opened the event in the debugger, it'd have been fine.

Perhaps having a "read-only" or "Inspect" mode for the debugger would help? The way the inputs work in the VEE, I move stuff around all the time by accident, and get super-worried when the debugger asks "do you want to save changes?" for an event I don't believe I changed, particularly given the above.

Debugger bug: Search for references throws an exception, presumably because you can't load arbitrary events from disk in the debugger. (Which is a limitation I'd like to see removed, as the 'Edit' button on remote event details is super fast compared to browsing around the disk and/or expanding levels in the Debug Event tab, for tracing complex logic.

Actual bug out of the above: Gossip girl objects in Rooftop\SmithYLMeeting don't survive reload, and now SmithYLRumours can't progress. (I reloaded SmithYLMeeting because I wanted to undo the hacking I'd used to bypass the delay since I was just rerunning it to fix state from the earlier issue. And now I have two randomly HasQuest-marked students I don't know who they are. Edit: Their _Names_ survive reload, and that's what's being used from SmithYLRumours. Not sure why I got a 'Null object', need to run the event again under the debugger. Possibly not reloading SmithYLRumours means the remove references are pointing to the old version?

Edit: Yeah, reloading SmithYLRumours after SmithYLMeeting now correctly shows the names in the debugger. So something to watch out for when reloading events. Not sure if this is a bug, or just par-for-the-course when reloading events, that you have to reload anything that references variables from that event too.

The NPC info panel's Preferences tab's Orientation value seems broken. A female with Female 67, Futa 39, Male 62 is showing "Heterosexual", although I guess that's possibly an undiscovered futa? In a more general sense, I'm seeing a lot of people marked "Bisexual" even if they only have one gender-attraction >= 50, e.g. a female student with attraction scores Female 19, Futa 19, Male 86 is showing "Bisexual". A futa student with attraction scores Female 81, Futa 63, Male 34 is showing as "Heterosexual" (and I'm not sure what the _right_ answer is there). A Special Character example: Lilly Rosenlace is Female, with attraction scores Fem 5, Futa 5, Male 100 from the XML, and shows as Bisexual. This one is trivially Heterosexual, suggesting something rather basic is wrong.

Looking closer, this one might actually be an engine bug, as the "Persons" debug view suggests it's an engine-level auto-calculated status. I'm guessing this same logic is used in the Person Likes Gender VEE node, but its description assumes that non-futas always like futas, while the current gender-attraction system does not.

The main reason I raise this one is that a person's gender-attraction word unlocks at a lower relationship level than the actual bar-graphs, so it's an earlier clue that a given NPC is never going to be in the MC enough to do the latter flirts, for example. Except almost everyone shows as Bisexual, when they may have scores like Lily Rosenlace above.

Just noticed this in the OP:

Quote from: barteke22 on May 27, 2022, 11:39 PMFixed GetWillingness inverting friendship bonus.

For self-help purposes, is this just changing the 'Subtract' to an 'Add' for the final Double Math node in GetWillingness? The comment in makes clear that at some point this was a "Dislike" penalty rather than a friendship bonus, and also shows *2 rather than /2.

In Btn_OrderProstitute, the P2 discount check (Node 1004) is off-by-one. The discount stages are 4, 6, and 8, but the tests are <3, <5, <7, >=7. Those tests should be <4, <6, <8, and >=8. I noticed this when I got a 30% discount from the expected price at the time P2 told me her stage name Velvet.

Mild text issue in June PersonAttachedEvents\Perrier\JuneTalk: The opening text talks about travelling to June's place (and has branches depending on whether she was at work or not), but you can also trigger this event in her home. Specifically, I knocked on the household door, Rie let me in (and gave me a spare key, which is a new event to me; not sure if that's generic but I'll be exploring it), and then I entered the loungeroom and the event triggered. So I guess the logic here hasn't been updated since the introduction of knocking, as before that, you couldn't be in the home except by breaking in, triggering the "hide behind the couch and escape" sequence.

I think this is a bug in Location\School\Principal Office\BellsStrip: The code that sets bit 5 (to trigger one-time text and a diary update) bypasses the code that applies the stat changes; see the output link of node 96. I suspect it should be hitting the ">=50" path (Inhibition, Lust, Willpower), as that's what subsequent repeats will do, and at this point it's already added 50-56 to her corruption. But maybe it's supposed to hit the "<50" path (Corruption, Willpower)?

Not totally sure what happened here, but there's possibly an issue in the logic for Miniquest_AerosolDrug. It appears to be trying to return only half the friendship reward if the drug is too low-level, but giving Felicia Titsbig (post-quest, Corruption 60) a level 1 Corruptor rewarded full points but introduced no corruption change.

It looks like it's trying to use the Accept test from Interactions\Items\Aerosol_Corruptor, but that only checks for inventory (already checked in this case) and for awake-but-cold-shoulder which doesn't make sense in a gift-giving situation. The test for "Did it work" in that file is: after the Corruptor is applied via executing ItemEvents\Corruptor_ItemEvent, it checks the change in Corruption level. So I suspect that test would need to be copied over into this file to achieve the desired effect. (I assume but didn't check if SlutMaker works the same way here, but I assume it does.)

The budget screen says that monthly costs happen on the first day of the month, but they appear to actually happen on the last day of the month.

I thought this was mentioned already but search doesn't see it: The button for visiting people at the Apartment Building is missing. The "Visit anyone you know" button on the map works for people who live there, but I suspect it consumes extra time.

Also, possibly more of a feature request, but I think it'd be better if the generic-home location exit button looked like the specialised-home exit button i.e. image of the destination, rather than using a generic icon. Particularly when the colourful "Smallville" button is there (I keep hitting that one by accident). I think that "Smallville" button would be better as a Map button at the bottom of the screen, like other map-travel-from locations. I recognise that this is probably this way due to transitioning from the old generic apartments which weren't actually located in the world, but could only be reached from the map or "Your place". Edit: I noticed some of the generic home don't have the "Smallville" in their entrance.

On this note, it's a little weird that the only place you can sleep in these homes is the Master Bedroom. Personally, I expected if only one room was going to be sleepable in, it'd be the Guest Bedroom if any. (I sometimes use these homes to optimise sleep time to be near where I need to go first the next day.) It'd be interesting (but maybe too much effort) to allow sleeping in someone's bedroom based on relationship level. I also noticed you can't actively shower at anyone's home, but you can use their shower for sex events.

There was also a few times (at least two) where a Ask For Sex sequence led to "Your Home" for someone whose address I knew, but the exit button lead to a different location, so I couldn't immediately re-enter their home to trigger the spare key event. At the time, I assume I didn't have their address... I guess this means that "Your Home" is not actually using the same "home" that visiting them would use, perhaps that's also legacy from when all generic homes were "off the map".

Hmm, I have sex at someone's home (or otherwise get invited there), I probably should automatically know their address. Not sure if that happens or not. Or alternatively, if someone wouldn't tell me their address, it should probably reject or not offer the "Your place" option. That probably makes more sense.

Not sure this one's a bug, but I ran both Hardman routes (Sierra revenge and mandatory masturbation) so when I confronted Karin, was able to choose the route to take. I chose the mandatory masturbation route (Because I wanted to try the chemistry ally system) but noticed later I didn't seem to have the photograph from the sierra revenge route. I'm not sure if the photo was never an item but just a quest flag, or if it was destroyed when I choose the mandatory masturbation route.

I also noticed that you still can't store the Hooter photographs on your shelf once you reach 'dating' (and no longer need them to unlock the event with Peter each day). I know you can optionally still give them to Peter, but I'd like to be able to stick one copy of each in my photo album.

On this topic, I suspect the newspaper should not be storable until you've read the news stories, and also run the Nina Parker events that use it. It's not essential to the latter right now, but I noticed a note in the VEE that the author planned to make it required.

Is it a bug that people lie about their fetishes? I noticed a few people who said "No fetish" or gave a fetish, and that was reflected on the vanilla NPC sex-info tab, but flipping to the 'cheat' view with right-click revealed a(nother) fetish. The vanilla tab prompts you that you haven't asked (with "Unknown") but doesn't indicate "There's more here" in any way I could see. Maybe this is a relationship-level cap or something, I didn't see any kind of hinting towards this. The success text suggests that asking about fetishes is enabled by "Now we've had sex...", but I had one NPC with whom I'd done mutual vaginal fingering (futa MC) who rejected my question about fetishes, so I assume there's a stat basis somewhere. Probably relationship, since in that case, I was at one heart only, but the failure text mentions rapport, which I would have thought meant the friendship stat (and that was at full 10 hearts).

I recall that for one NPC the vanilla tab showed one revealed fetish and a second row for another unknown, but that was not always the case when there were unrevealed fetishes. Maybe that's the bug?


It it normal for oral sex to not reduce lust, but increase it?

Sometimes it seem when having handjobs/oral that arousal increases instead of decreases, even tough the text specified that the MC did cum.


Another thing that I noticed - I never see a trib option appear in Ask for Sex (MC is futa).
The code looks like spaghetti, but it seems like it is there, it just doesn't appear.

barteke22Topic starter

Quote from: ElPresidenete on Nov 03, 2023, 08:42 AMAnother thing that I noticed - I never see a trib option appear in Ask for Sex (MC is futa).
The code looks like spaghetti, but it seems like it is there, it just doesn't appear.

Dunno which code, but the AskForSex action provider says that trib is Fem-Fem only.  Likely due to lack of decent images (and as such also no text).


Maybe not good bug report and just observations. Delete if offtopic. with Annette and Andy mod. I tend to have all special npc students in first class.

Had two instances with
NormalSchool\Events\Location\School\Classroom Shared\ complaining about getting bunch of characters, when it needs only 2m and 1f during classes. Haven't noticed that in previous versions.

Got only two booms in chemistry leveling and both times MC went to hospital instead of ward. Karin was at school. Chemistry is at 100 with no Karin in the lab. Maybe just luck on that run.

In other run I missed Smith and Ollie visiting principal's office at 16:00 and I suspect they are not coming back.

Andy might have his love for principal thresholds set low cause he gets aroused on every small talk phone call. Same as in older versions.


Ginny converted to futa with Sierra's bear keeps getting gender override despite principal seeing her gender.